Service Disruption

Incident Report for Speakcore Status Page

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 07:58 EST

Identified

We have identified the root cause of the issue affecting all tenants, which resulted in unexpected logouts and random errors. To mitigate the impact, we have deployed a temporary workaround while we continue working on a permanent solution.

Our team is actively monitoring the system to ensure stability and is working toward a full resolution. We will provide further updates as we make progress. Thank you for your patience.
Posted Feb 20, 2025 - 11:32 EST

Update

Our team continues to investigate the issue affecting all tenants, causing unexpected logouts and random errors. We have deployed additional monitoring and data-gathering tools and have engaged with Microsoft, our cloud service provider, to help identify the root cause and implement a resolution.

We appreciate your patience and will provide further updates as soon as more information becomes available.
Posted Feb 19, 2025 - 09:07 EST

Update

We are still actively researching the root cause of the issue affecting all tenants, which is causing unexpected logouts and random errors. To assist in our investigation, we have deployed additional monitoring and data-gathering tools to collect more information.

Our team is working diligently to identify and resolve the issue as quickly as possible. We appreciate your patience and will provide further updates as soon as we have more details.
Posted Feb 18, 2025 - 17:06 EST

Investigating

We are currently experiencing an issue affecting all tenants, causing users to be unexpectedly logged out and potentially encountering random errors across the platform. Our team is actively investigating and working on a resolution.

We apologize for the inconvenience and appreciate your patience. Please check back here for further updates.
Posted Feb 18, 2025 - 11:20 EST
This incident affected: Speakcore App and Speakcore API.