System-Wide Performance Issues

Incident Report for Speakcore Status Page

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 16:25 EST

Monitoring

We've applied a temporary solution to mitigate the performance issues, and systems are showing signs of improvement. Our team is continuing to monitor stability while actively investigating the root cause. We appreciate your patience and will provide further updates as we learn more.
Posted Feb 07, 2025 - 13:21 EST

Investigating

We're aware of ongoing slowness and performance issues affecting all clients. Our team is actively investigating the cause and working to resolve it as quickly as possible. We appreciate your patience and will provide updates as we make progress. Thank you for your understanding.
Posted Feb 07, 2025 - 12:55 EST
This incident affected: Speakcore App and Speakcore API.